We are currently investigating issues with our database.

Started at Mar 12, 2024 18:07 (UTC)

Resolved

resolved

Mar 12, 2024 18:17 (UTC)

Problem has been solved.

investigating

Mar 12, 2024 18:07 (UTC)

We are currently investigating an issue with our database causing slowness of the system.